problem with new ghd styler

#1
I have just invested in stocking ghd straightners in my salon but have so far had 2 pairs stop working. The only connection is that I used them in my house instead of the salon in the same plug socket as my hairdryer and my own old straightners.(no prob with these) plus salon is attached to my house.

has any one else had a problem with these stopping working or knows of any one that has?
 

loubylou

Well-Known Member
#2
Sounds like a bad batch to me, i would get in touch with the distributor and have them exchanged :hug:
 

CadenceAlex

Well-Known Member
#3
I was just reading about these on MoneySavingExpert.com and they say it's a common problem and you could send them away in a silver bag and they would replace them free of charge.

Check out your warranty
 
#4
the first ones I sent back and the second ones are the replacement ones. thought it might be the socket but everything else works in them. Just have to explain to my hairdresser that I have caused these to stop working.
I am the salon owner and employ a hairdresser and beautician ( I seem to be the one spending all the money) I am cross because we are selling these to customers so I am waiting for those to be returned........only had them 2 weeks!!!! :mad:
 

JDs

Curly Hair Geek
#5
It really does sound like a possible bad batch, but if you are worried about the ones you sold, if you have the clients names you sold them too, call them and confirm that theirs is working. At least this will narrow down the problem to a bad batch or your inlets shorting them out.

You can also go to the manufacturers website and see if there is anyone complaining about them.

I had a similar problem with my credit card pinpad, we were having a problem and the manufacturers had to keep sending out new ones to me, they tried to tell me that is was something I was doing to them when in fact it was how they were programing the pinpads..Finally got it right after the 4th one. So It could be just the chance you got two bad ones in a row.
 

minky

Well-Known Member
#6
the first ones I sent back and the second ones are the replacement ones. thought it might be the socket but everything else works in them. Just have to explain to my hairdresser that I have caused these to stop working.
I am the salon owner and employ a hairdresser and beautician ( I seem to be the one spending all the money) I am cross because we are selling these to customers so I am waiting for those to be returned........only had them 2 weeks!!!! :mad:



HI there, on watchdog a good few months back they were telling people to make sure they turned them off at the plug and not just by the switch that is on the straighteners ,apparently when they had been turned off by the switch only , some people complained that they were igniting and were a fire hazard,:eek: Watchdog reckoned they were a faulty batch ,and it is to do with the switch on the straighteners . The manufactures said they could find no fault but have been replacing them , I would send them back
every single time, and turn them off at the plugs especially when you lock up for the evening .:) minky.
 
Top