NSI Technails kit - problem with black

SalonGeek

Help Support SalonGeek:

larnie

Well-Known Member
Joined
Jul 2, 2007
Messages
130
Reaction score
1
Location
Isle of Man
I've only just started using the kit and found that when I mix colours with the black that it doesnt mix well and when applied it leave black streaks in the acrylic.

Is there something wrong with the powder or am I doing something wrong. i've emailed NSI but I thought someone might know on here.

Also, I cant get any colours to match the chart, I have to do my own mixes to get the colours.:rolleyes:
 

pips

Well-Known Member
Joined
Feb 6, 2006
Messages
2,225
Reaction score
71
Location
West Yorkshire
I've only just started using the kit and found that when I mix colours with the black that it doesnt mix well and when applied it leave black streaks in the acrylic.

Is there something wrong with the powder or am I doing something wrong. i've emailed NSI but I thought someone might know on here.

Also, I cant get any colours to match the chart, I have to do my own mixes to get the colours.:rolleyes:
From past experience using the technail kit the black can be a swine to use. I dont know if its because of the cvolour pigment but it can stain the tip/nail plate if you work a little too wet (kinda seeps all over) infact most of the dark pigmented colours can do this, red, purple, dark green, black, etc so try working a little drier if you can.

The colour chart i have found looks nothing like when you use the colour mix guide, its only once you start working with the mix and it has dried and you have filed, buffed, shone that you get the true colour so maybe give it a try with a few mix guides and see how it goes. HTH
 

ladybgemini

Well-Known Member
Joined
Jul 19, 2005
Messages
2,326
Reaction score
142
Location
Cannock, Staffordshire
The mixing chart relates to the older technail kit hun, there isn't one for the new kit. some of the colours in the older kit have been replaced with the glimmer ones but you can still get the older colours in single pots on the site (I think)

HTH

Rachel
 

sweetiepie

Active Member
Joined
Oct 12, 2006
Messages
41
Reaction score
1
Location
Marbella
I've only just started using the kit and found that when I mix colours with the black that it doesnt mix well and when applied it leave black streaks in the acrylic.

Is there something wrong with the powder or am I doing something wrong. i've emailed NSI but I thought someone might know on here.

Also, I cant get any colours to match the chart, I have to do my own mixes to get the colours.:rolleyes:
Ive used the Black NSI gel and it is really weak in pigment. I have to put on about 5 layers for it to be a strong enough black.

So its not just the Acrylic
 

looby lou

Well-Known Member
Joined
Nov 6, 2005
Messages
516
Reaction score
23
Location
leigh, lancashire
as pip said, it's because you are working too wet. I always blot the excess liquid out of the back of my brush before applying. If you still get any residue you can wipe over the nail with a dehydrator, ie, swipe or cleanse.

Also, I always apply a dark colour to all 10 nails then, and this is soooo important!, clean your brush and use fresh monomer for applying pink.

HTH xxxx:lol:
 

ladybgemini

Well-Known Member
Joined
Jul 19, 2005
Messages
2,326
Reaction score
142
Location
Cannock, Staffordshire
Ive used the Black NSI gel and it is really weak in pigment. I have to put on about 5 layers for it to be a strong enough black.

So its not just the Acrylic

I had this problem but on closer inspection all of the pigment had sunk to the bottom of the pot. You need to get a clean gel pot and tip the black gel into it and scrape the pigment off the bottom to mix it all in properly. Keep it stirred everyday and it should be solid black.


HTH

Rachel
 

Latest posts

Top